SSRS help. Subreport could not be shown

(Shawn Hobdy) #1


I modified the purchase order form a year ago and it worked fine.

I just copied it to the test database to look at some changes.

When I run it before I make any changes, I get the ‘subreport could not be shown’ on the report.

It works fine in Production.

My question is, is there some log somewhere that can give me more info on why it couldn’t be shown?

Any hints, tips, etc on how to troubleshoot?

Thanks in advance,


(Graeme Fraser) #2


there are log files in the ssrs server directory. the sub report will prob b hardcoded to the production directory rather than the current one. take the full path out the sub Report and just leave the sub Report file in the sub Report properties.


(Shawn Hobdy) #3

I finally found the logs and ran another report to find the correct log section.

Turns out, in Production, I had to hard code a join to the Productions SQL server in order to get a certain piece of info into report.

Once I found what the issue was in the log, it jogged my memory and I was able to find it and modify for the test environment.

It worked like a charm!

In case anyone else is looking, my logs were in the:

E:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services\LogFiles

E: is where SQL was installed and the MSRS12.MSSQLSERVER can be different for other people depending on the SQL server installed.

Hope this helps other people when trying to find the SSRS logs

Thanks to @Graeme_Fraser for their quick reply. I really appreciate all the help I get in!