Report Error on TEST


(Matt Helfrey) #1

We are are getting this error when printing reports from our TEST environment, LIVE is OK for now.


I’m looking for any insight into what is causing this, support suggested that it could be caused by a Windows Update applied to the server - Case CS0001187330

We tried to re-deploy the Reporting Services in the Admin Console and get this error. The SSRS URL is the same in LIVE and that works.

Any hint of corner to pry under would be helpful.

(Jason Stephens) #2

Have you validated that you can access the SSRS URL from the app server? You should get a directory listing showing the different root folders when you go to the SSRS Web Service URL from the config.

If nothing shows up, start troubleshooting SSRS itself via the Reporting Services Configuration Manager on the EpicorSQL server. Double-check the Web Service URL section and verify that URL is working and matches what is entered in the Epicor configuration. There could be a port specified if you aren’t using the default port 80 or SSRS itself could be stopped.

If you do see the directory listing, verify the EpicorTest10 root directory exists. Epicor should create it for you but there could be some issue preventing that. Create it if it doesn’t exist and see what happens. Or, if it does already exist, check out what’s in it and see if it matches the structure of your live environment (i.e. /root_folder_name/reports/a_bunch_of_report_folders).

(Matt Helfrey) #3

Thanks Jason for the good suggestions. We have checked these and they appear to be correct, we still cannot print from TEST.

For what it’s worth (you guys are the best), Epicor has given up on solving the issue and pointed us here …

(Olga Klimova) #4

So if you open in browser http://EpicorSQL/ReportServer/EpicorTest10 - you see the list of your reports?

(Matt Helfrey) #5

Yes, we can see the reports.


I DO get an error if I look at the Reports address.

(Olga Klimova) #6

So you can connect, but you still get 404 error in System Monitor? or it is another error now?

(Matt Helfrey) #7

I can see the reports in //epicorsql/ReportServer/EpicorTest10
I cannot load the //epicorsql/Reports

I still do get the 404 error in System Monitor when printing.
I still cannot deploy Admin Console.

Reports are still working in LIVE.

(Olga Klimova) #8

But if LIVE on the same machine and works fine, then http://epicorsql/Reports accessibility should not be the root problem, i think.

What is in the SSRS log? probably there is more infortmation about error?

(Jason Stephens) #9

What exactly does your test environment look like? I get that you’re running the reports from the same location - what about the app server? Is it the the same server for both? Is the application pool in IIS running under the same identity for both?

(Matt Helfrey) #10

Olga, I am not sure what Log file you are referring to, the log shown below does not show any errors from reports printed from TEST, is this the correct Log?

Attached is the log fileReportServerService__10_16_2018_00_05_56.txt (213.9 KB)

(Matt Helfrey) #11

Jason, LIVE and TEST are running from the same APP and SQL Server.

I think the IIS Pool is under the same identity, this is where my knowledge runs out. How do I know?

(Olga Klimova) #12

it is mentioned in the end, search for EpicorTest10. This is probably when you open it in browser,
But i don;t see anything about printing report. Are you sure that your web.config and company settings really point to that SSRS folder. 404 error looks strange.

(Jason Stephens) #13

Expand the Default Web Site in the Connections pane (left side of screen), right-click the application and select Manage Application > Advanced Settings. The application pool used for the application will be listed at the top of the resulting screen. Do this for both LIVE and TEST and make a note of the application pool used for each. I suspect that LIVE will be running under a domain account while TEST will be ApplicationPoolIdentity.

Then go to Application Pools in the Connections pane and take a look at the identity. If they’re different then match TEST to LIVE. You can change the identity by right-clicking the application pool, selecting Advanced Settings, clicking the in the Identity field, click the […] button that shows up, click Set, and specify the user/password. Make sure to stop/start the application pool (Actions pane, right-hand side) after changing the user to restart the application pool under the new context. Wait a couple of seconds and then click the Refresh button at the top right (all the way up near the close button) of the screen and verify that the application pool remains started.

I agree with @Olga, the 404 is strange because we can view the report directories in a browser. What’s listed in the web.config for the application? You can check by right-clicking the TEST application in IIS, selecting Explore, and opening the web.config file with your favorite text editor. The values of interest are SSRSBaseURL and SSRSRootFolder.

(Matt Helfrey) #14

A) Both the LIVE and TEST match in the Advanced Settings. Should there be a ‘Physical Path Credentials’?

B) Application Pool Identity match for LIVE and TEST

C) the web.config files did NOT match for LIVE and TEST. TEST was missing the SSRSBaseURL altogether, so I copied that line from the LIVE config to TEST config.

That has changed something, I now get a different error when running a report in TEST.

Program Ice.Services.Lib.RunTask raised an unexpected exception with the following message: RunTask: An error has occurred during report processing. —> Microsoft.ReportingServices.ReportProcessing.ProcessingAbortedException: An error has occurred during report processing. —> Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: Query execution failed for dataset ‘OrderHed’. —> System.Exception: For more information about this error navigate to the report server on the local server machine, or enable remote errors

I will reboot the servers tonight when there are no users online and test again.

Thank You for the excellent suggestions Jason and Olga.

(Olga Klimova) #15

set SSRSRootFolder to ErpTest10 in the web.config for test environment

(Philip Hugos) #16

Is this problem already solve?

(Matt Helfrey) #17

This issue is now partially solved. Reports are now printing from TEST.

Big thanks to Jason and Olga!

My TEST web.config file was corrupt.

  1. appSettings - SSRSBaseURL entry was missing en
  2. appSettings - SSRSRootFolder value was empty
  3. connectionStrings - ReportData entry was missing

Open Issues

If I click the Deploy button in the Admin Console for Reports, the web.config file drops these values.
I still cannot navigate to the http://epicorsql/Reports url.

I have schedule some time with an SSRS consultant for this Friday and will report back the findings.

Thanks again for the help.

(Matt Helfrey) #18

Final resolution.

A uninstall and reinstall of SQL Reporting Services fixed the problem.